wxPython build error EventToken.h not found

wxPython build error: EventToken.h not found

Dear all,
I get build error when installing wxPython. The error seems related to the wxWidgets compilation.
I am using python 2.7.18 on windows 10 machine with updated wheel, setuptools and pip.
I have installed Microsoft Visual C++ 9.0 and the “requests” python module.ì since I realized these were required during previous installation tentatives.
It seems the building of wxWidgets that fails before the build of wxPython.
When I run the command “python -m pip install -U wxPython” the installation fails with the following message:

c:\users\polimigasdyn\appdata\local\temp\pip-install-_ybqhu\wxpython\ext\wxWidgets\3rdparty\webview2\build\native\include\Webview2.h(411) : fatal error C1083: Cannot open include file: ‘EventToken.h’: No such file or directory
NMAKE : fatal error U1077: ‘“C:\Users\polimiGasdyn\AppData\Local\Programs\Common\Microsoft\Visual C++ for Python\9.0\VC\Bin\amd64\cl.EXE”’ : return code ‘0x2’

I wanted to attach the log file with the complete output but I am not allowed me since I’m new user.
I report below the whole output, except the many lines about the successful compilation of some files.
Maybe i can install already buildt wheels ?
I hope you can help me,
Best regards,

Hi all, I’ve solved installing the pre-compiled wxPython from .whl files downloaded from: pre compiled for windows.
I found this link helfull also for fixing installations of other modules.

For the record, the error is probably due to a missing, misconfigured, or too old Windows SDK on the build machine.

Also, you get get official builds from PyPI of older versions that included Python 2.7 binaries, by specifying the version number. Like this:

python -m pip install -U  wxPython==4.1.0