Minimum macOS version?

Hi there,

I’ve been having issues running wxPython 4.1.1 on macOS 10.9 Mavericks. I just tried a manual build and noticed that it seems to be building for a minimum macOS version of 10.10.

Is this a system requirement now, or just the way the build script runs by default?

Also, what’s the minimum version for the wheels on pip? I thought they would run on Mavericks (they always used to) but perhaps the requirement has changed.

Apologies if this is a stupid question, but I couldn’t find a page on this anywhere for recent wxPython versions.


Never mind, just found it at wxWidgets: Introduction

wxWidgets 3.1.x requires macOS 10.10, up from 10.5 that was required for 3.0. I guess this is where it’s coming from then. Apologies for the noise.

No problem. It’s not noise if it helps someone searching for the same answer in the future. :slight_smile:

There is some discussion about this change here: