Legacy-install-failure × Encountered error while trying to install package. ╰─> wxPython

I am trying to install robotframework-ride in mac os but i getting this error the python version is 3.9.13 and pip version is 22.3.1 i trying to resolve this issue but i fed up with this
please let me know proper step.

C0DD48AB-A876-4765-9245-71FA03B1BFBC