How to debug wxpython 2.8.12.1

Hello.
Please help with this issue:
I’m trying to start old version of python ride, which uses this version of wxpython.
I have this version of wxpython installed:
wx.version()
‘2.8.12.1 (msw-unicode)’.
my python version:
Python 2.7 (r27:82525, Jul 4 2010, 07:43:08) [MSC v.1500 64 bit (AMD64)] on win32.

I’ve downloaded and installed the demo for this version (wxPython2.8-win32-docs-demos-2.8.12.1.exe).
but when I run it - nothing happens:
c:\Program Files (x86)\wxPython2.8 Docs and Demos\demo>demo.py

c:\Program Files (x86)\wxPython2.8 Docs and Demos\demo>

Maybe something’s up with your file associations or PATHEXT setting. What happens if you invoke the interpreter explicitly, py -2.7 demo.py or python demo.py?

when I run python demo.py also nothing happens:

I have been trying to help @Alexander_Kukharchuk because this is one strange situation. He had previously a fully working RIDE (wxPython), but then some unknown conflict happened because of using python3 even if in a separate installation.

We tried a basic example, but still no error or message. I ask Alexander to try the new version below.

Hello World code
#!/usr/bin/python2
import wx

print "This app is running with wxPython version ", wx.VERSION
app = wx.App()
frame = wx.Frame(None, wx.ID_ANY, "Hello World")
frame.Show(True)
app.MainLoop()
1 Like

I made a new file wxtest1.1.py with the code you suggested:
#!/usr/bin/python2
import wx

print "This app is running with wxPython version ", wx.VERSION
app = wx.App()
frame = wx.Frame(None, wx.ID_ANY, “Hello World”)
frame.Show(True)
app.MainLoop()

I run and have the same result:


it shows the version , but then nothing happens.

I tried changing path in the first line to my actual path:
#!c:\Python27\python.exe
ran it - and still the same result, nothing happens

I uninstalled python,
then used CCleaner to delete every instance of any python from registry.
then installed python 2.7 and wxPython2.8-win64-unicode-2.8.12.1-py27 again.
and still nothing - when I run python demo.py, nothing happens:
c:\Program Files (x86)\wxPython2.8 Docs and Demos\demo>python demo.py

c:\Program Files (x86)\wxPython2.8 Docs and Demos\demo>

I uninstalled wxPython 2.8.12.1
and installed
wxPython3.0-win64-3.0.2.0-py27.exe
and it worked:
I get this warning first:

but after that it opens:

but ride doesn’t work with this version.
I tried 2.9.1 - same situation

upd:
c:\Python27\Lib\site-packages\robotide_init_.py
file
changed:
supported_versions = [“2.8”]
to
supported_versions = [“2.9”]
and now ride finally launches

so the question actually remains:
how to debug wxpython 2.8.12.1 or 2.8.12.0 to see why it doesn’t run any demos,
while 2.9 does.

You may be the first person to try this very very ancient wxPython+python combination on a recent Windows 10. Usually people who are stuck on 2.7 at least use the latest 2.7 that has an installer, which is 2.7.15 from 2018. Also, there may be issues particular to the 64-bit versions; most people used 32-bit in 2010.

Your time may be better spent updating this RIDE thing to run on something more recent.

I doubt this is anything - but there are two site-packages in the directory you are displaying in the background of the pic. I have never seen that on any installation on any platform.
Johnf

Yes.
I have two windows10 on different drives, both having python and ride, it’s been working like that for years already.
and ride (and wxpython) stopped working on the windows that I’m updating sometimes (install windows updates).
and the ride on the older windows 10, which I haven’t updated for a long time (a couple of months) - it keeps working.

I can’t update ride right away, because it doesn’t support old syntax (for loops), and we have a lot of projects written in old syntax, we’re slowly updating them in parts.

as for python version - I can unistall python 2.7 and install 2.7.15 instead, if there’s a chance that this combination:
python 2.7.15 (or Python 2.7.18) + wxpython2.8.12.1 will work on windows10 with recent update

no,updating python from 2.7 to 2.7.18 didn’t work:
Python 2.7.18 (v2.7.18:8d21aa21f2, Apr 20 2020, 13:25:05) [MSC v.1500 64 bit (AMD64)] on win32
demo.py doesn’t start with wxpython 2.8.12.1

By update I meant do the work yourself. Make a branch of the sources for the old version (assuming you have sources for it), and make whatever changes are necessary to get it running with a slightly more recent wxPython.

thank you, that’s pretty much exactly what I did:
I changed
c:\Python27\Lib\site-packages\robotide_init _.py
supported_versions = [“2.9”]
after that ride started working, with a few minor glitches thought, but so far I can ignore them and keep working like this, until we finally migrate all project to the new ride.

just in case, here’s my windows update history:

ride (and wxpython) stopped working between these dates 4.11-8.11

what’s weird is that I looked at my colleague’s updates and he’s got pretty much the same ones:

but his version of ride 1.2.1 (and wxpython 2.8.12.1) still working without any issues