Having trouble installing wxPython on Ubuntu

I am on Ubuntu 20.04 and I have Python 2.7. I am trying to install wxPython version, from the source. I ran ./configure, make, and make install and now apparently I need to run python wxPython/build-wxpython.py according to this post. When I do so, it fails. Here is what I believe is the relevant output:

checking for GST... configure: WARNING: GStreamer 0.8/0.10 not available.
configure: error: GStreamer not available
Error running configure
ERROR: failed building wxWidgets

Now, I have installed GStreamer 1.0 by running apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgstreamer-plugins-bad1.0-dev gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio as instructed here but it’s not working. Am I supposed to install GStreamer 0.10 and if so how do I do that? Did I make a mistake or miss something?

Thanks in advance.

Additional info: When I run import wx in Python it gives the following error.

>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.7/dist-packages/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/local/lib/python2.7/dist-packages/wx/_core.py", line 4, in <module>
    import _core_
ImportError: No module named _core_

Does this indicate a wrong or incomplete step I followed at some point? If so how do I fix the situation?

To build that extremely old version of wxPython, yes, you need GStreamer
0.10 or 0.8. I doubt it was shipped with that version of Ubuntu (it was
removed from Debian in 2016), so you might have to build it yourself if
you really want to use that version of wxPython.

Out of curiosity, why do you want to use that version of wxPython?


Thanks Scott for your help. I am working on a legacy software which was written many years ago and apparently used that old version.

The No module named _core_ issue makes me think at least something has been installed, but not working properly. Do you know any steps to diagnose the problem?

I might be barking up the wrong tree entirely. I have no experience in almost anything related to this project and neither do any of my coworkers.

The issue might be similar to that faced here, but I am using python 2 instead of 3.

The _core_ module is produced by the build so if your build is not succeeding then it will not be there, as the error message indicates.

I expect that there is a good chance that updating the application to work with current modern wxPython, wxWidgets and Linux would be easier than to trying to get the ancient (8 years old!) version of wxWidgets and wxPython built on a modern Linux and Python.

Thanks for your help Robin.