Wxbase314u_vc140.dll missing in 4.2.0 32bit

Just upgrade from 4.1.0 to 4.2.0, python 3.8 win10 32bit.
Everything works fine except when running nuitka to generate any wxpython components.

FATAL: Error, attempting to include file ‘c:\users\admin\appdata\local\programs\python\python~1\lib\site-p~1\wx\wxbase314u_vc140.dll’ that does not exist.

Is it some static link not tidy up in wxpython or from wxwigets?

works on

Device name George-PC
Processor Intel® Core™ i5 CPU M 430 @ 2.27GHz 2.27 GHz
Installed RAM 4,00 GB
Device ID B727C96C-D730-4BB3-8CEF-3DDAAF376F87
Product ID 00326-10000-00000-AA972
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Successfully installed Nuitka-1.0.4

C:\Users\Me>cd C:\Users\Me\Documents\Programming\Python\Mylib

C:\Users\Me\Documents\Programming\Python\Mylib>python -m nuitka --onefile MywxApp.pyw
Nuitka-Options:INFO: Used command line options: --onefile MywxApp.pyw
Nuitka:WARNING: Using very slow fallback for ordered sets, please install ‘ordered-set’ PyPI package for best Python
Nuitka:WARNING: compile time performance.
Nuitka:INFO: Starting Python compilation with Nuitka ‘1.0.4’ on Python ‘3.10’ commercial grade ‘not installed’.
Nuitka-Plugins:INFO: multiprocessing: Injecting pre-module load code for module ‘multiprocessing’:
Nuitka-Plugins:INFO: multiprocessing: Monkey patching “multiprocessing” load environment.
Nuitka-Plugins:INFO: multiprocessing: Injecting post-module load code for module ‘multiprocessing’:
Nuitka-Plugins:INFO: multiprocessing: Monkey patching “multiprocessing” for compiled methods.
Nuitka-Plugins:WARNING: Use ‘–enable-plugin=numpy’ for: Numpy may miss DLLs otherwise.
Nuitka-Plugins:WARNING: Use ‘–enable-plugin=pyside6’ for: Standalone mode support and Qt plugins.
Nuitka:INFO: Completed Python level compilation and optimization.
Nuitka:INFO: Generating source code for C backend compiler.
Nuitka:INFO: Running data composer tool for optimal constant value handling.
Nuitka:INFO: Running C compilation via Scons.
Nuitka-Scons:INFO: Backend C compiler: cl (cl 14.2).
Nuitka-Scons:INFO: Backend linking program with 119 files (no progress information available).
Nuitka-Scons:INFO: Running ‘link @C:\Users\Me\AppData\Local\Temp\tmpzkq5u3jd.lnk’ took 532.55 seconds
Nuitka-Scons:INFO: Compiled 119 C files using clcache with 0 cache hits and 119 cache misses.
Detecting used DLLs: 0.0%| | 0/41, MywxApp.exeNuitka will make use of Dependency Walker (https:/
/dependencywalker.com) tool
to analyze the dependencies of Python extension modules.

Is it OK to download and put it in ‘C:\Users\Me\AppData\Local\Nuitka\Nuitka\depends\x86_64’.

No installer needed, cached, one time question.

Proceed and download? [Yes]/No
Nuitka:INFO: Downloading ‘https://dependencywalker.com/depends22_x64.zip’.
Nuitka:INFO: Extracting to ‘C:\Users\Me\AppData\Local\Nuitka\Nuitka\depends\x86_64\depends.exe’
Nuitka-Postprocessing:INFO: Creating single file from dist folder, this may take a while.
Nuitka-Onefile:INFO: Running bootstrap binary compilation via Scons.
Nuitka-Onefile:WARNING: Onefile mode cannot compress without ‘zstandard’ module installed.
Nuitka-Scons:INFO: Onefile C compiler: cl (cl 14.2).
Nuitka-Scons:INFO: Onefile linking program with 1 files (no progress information available).
Nuitka-Scons:INFO: Compiled 1 C files using clcache with 0 cache hits and 1 cache misses.
Nuitka-Onefile:INFO: Keeping onefile build directory ‘MywxApp.onefile-build’.
Nuitka:INFO: Keeping dist folder ‘MywxApp.dist’ for inspection, no need to use it.
Nuitka:INFO: Keeping build directory ‘MywxApp.build’.
Nuitka:INFO: Successfully created ‘MywxApp.exe’.


but it takes a long time… :sleepy:

Thanks, then the problem is more on 32bit, which needs to compile during pip install wxpython

I have tried to reinstall python from scratch, but still the same.
Just found and delete the cached Nuitka folder.
Everything is ok finally. Thanks.

that should really be mentioned on the Nuitka page, but understandably Nuitka is generating quite a lot of stuff & one better keeps the print-out
what I have noticed is that it is more restrictive on imports, f.i. one can import wx.lib.plot as a whole and then use all its classes: but not with Nuitka (maybe only the commercial version has all the chrome?) :pouting_cat: